Apr 13 2016

Ubuntu 14.04 LTS – SSH Anmeldung als root erlauben

Standardmäßig ist ein direkter root-Login per SSH an einem Ubuntu 14.04 LTS nicht möglich.

Um dies wieder zu (re-)aktivieren, müssen folgende Dinge ausgeführt werden.

1.) per normaler User anmelden und das Passwort für den root-User setzen

2.) Die ssh-Config bearbeiten

Folgende Zeile ändern:

3.) ssh Daemon neu starten

Nun sollte der SSH Zugriff als root möglich sein.

 

Hinweis: das standardmäßige Deaktivieren des root Zugriffes per SSH geschieht nicht durch Zufall -> dies hat Sicherheitsgründe!

Sei dir bitte daher im klaren, welches Risiko du (durch das ermöglichen des root Logins) damit eingehst.

 

Viel Spass nun beim testen …

Apr 11 2016

kostenloses Upgrade von Windows 7 auf Windows 10

Hallo zusammen,

aktuell bietet Microsoft bis Ende Juli 2016 ein kostenloses Upgrade auf Windows 10 an

Voraussetzung ist, das das aktuelle Windows 7 (oder 8 oder 8.1) korrekt lizenziert und aktiviert ist.

Beim Upgrade wird die jew. Edition berücksichtigt. D.h. (Windows 7 Home -> Windows 10 Home; Windows 7 Prof. -> Windows 10 Prof.).

Es gibt jedoch auch Ausnahmen wie z.B. Windows 10 Enterprise, für welche kein kostenloses Upgrade zur Verfügung steht.

 

Ich selbst habe ein Windows 7 Prof. auf einem Notebook – anbei (meine) Vorgehensweise:

1.) komplettes Backup / Image des aktuellen Zustandes erstellen.

2.) Backup kontrollieren (nur für alle Fälle, um ggf. zurück zu Win 7 zu können)

3.) Unnötige Software löschen (darunter z.B. so Mist wie CCleaner (falls installiert) und Co.)

4.) Ruhezustand von Windows deaktivieren

Dazu eine CMD (=> mit „Als Administrator ausführen“ starten und folgendes eingeben:

5.) Virenscanner deinstallieren

Ja, richtig gelesen. Deinstalliere den aktuell unter Windows 7 aktiven Virenscanner.

Zum einen damit dieser nicht den Upgradeprozess stört und zum anderen damit dieser nachträglich unter Windows 10 keine Probleme verursacht.

Nach dem erfolgreichen Upgrade auf Windows 10 kann der Virenscanner wieder sauber neu installiert werden.

6.) Media Creation Tool ausführen

Download des Media Creation Tool zum Ausführen den Windows 10 Upgrades oder des Erstellen eines entsp. ISO-Files

Ich habe mich entschieden, das Erstellen des ISO-Files zu nutzen – aber das ist jedem selbst überlassen.

Diese muss nach der Erzeugung auf einen DVD Rohling gebrannt werden.

7.) Setup.exe auf Zielcomputer ausführen

Den Rechner (in meinem Falle ein Notebook) mit dem jew. Betriebssystem starten (Windows 7), DVD einlegen und die „Setup.exe“ starten.

Nach dem Start kann dem Wizard einfach gefolgt werden. u.a. kann nach Updates gesucht werden,

Es wird auch geprüft, ob genügend Speicherplatz zur Verfügung steht.

Win10-Upgrade_2

Ebenso lässt sich auswählen, ob die bereits installieren Programme sowie Einstellungen behalten werden sollen – oder auch nicht.

Das Setup prüft auch, ob bereits installierte Programme inkompatibel zu Windows 10 sind.

Win10-Upgrade_1

Ready ?

Win10-Upgrade_3

Wird der Prozess dann gestartet, heisst es erst mal – Pause machen, das läuft ne ganze Weile …

8.) „Optional“ – Fehler beheben ;-(

Super, mein Windows 10 Upgrade bricht ab mit folgender (vielsagender) Meldung.

Win10-Upgrade_4

Eine Logdatei zum Upgradevorgang findet sich unter

… dort steht der genaue Fehler.

Nach längerer Suche bin ich auf folgendes in der Registry aufmerksam geworden.

Win10-Upgrade_5

Hierzu hatte ich mal ein Notfall DVD aus einer Fachzeitschrift erstellt, jedoch hatte diese Software in der Registry den Wert „ImagePath“ verbogen.

Der Pfad sollte aber wie folgt lauten:

Win10-Upgrade_6

Anbei der Registrypfad:

 

Nachdem ich diesen korrigert hatte, lief das Upgrade auf Windows 10 erfolgreich durch.

 

Viel Spass beim Testen …

PS: Installation des Virenscanners unter Windows 10 nicht vergessen 😉

 

Apr 07 2016

Update Redmine von 3.1.2 auf 3.2.1

Basierend meinen Beitrag http://www.small-blog.de/update-redmine-3-0-2-auf-3-0-3-auf-einem-ubuntu-14-04-lts/ habe ich ein weiteres Update ausgeführt und dies hier dokumentiert.

 

Vorweg: Der nachfolgende Aufschrieb ist lediglich eine Niederschrift zu meiner Umgebung – diese kann ggf. mit deiner Umgebung abweichen!

Aktuell läuft auf einem Ubuntu 14.04 LTS eine bestehende redmine Installation in Version 3.1.2 – diese soll nun auf die Version 3.2.1 aktualisiert werden.

  • 1. Backup!

Sichere VOR dem Updatevorgang die Datenbank sowie die Dateistruktur.

  • 2. Backup kontrollieren

Nur für alle Fälle …

  • 3. Originalverzeichnis umbenennen bzw. wegkopieren

  •  4. Download der neuen Redmineversion und anschließend entpacken

  •  5. Vorherige Configs + bisherige Daten auf neue Redmineversion kopieren

  •  6. Nun das eigentliche Update ausführen

  • 7. Zum Schluss noch die Rechte prüfen bzw. setzen

  •  8. Nun noch den Apache mal durchstarten

Anschließend solltest du dich auf der (aktualisierten) redmine Installation anmelden können.

Unter Administration => Information sollte anschließend

zu sehen sein.

Viel Spass nun beim testen …

Mrz 07 2016

Windows 10 – Upgrade von Windows 7 / 8 / 8.1 verhindern

Ihr nutzt Windows 7 oder 8 oder 8.1?

… und ihr wollt das Windows 10 Upgrade nicht haben?

Kein Problem.

Nachfolgendes kopieren, als .reg Datei speichern in importieren.

Rechner noch rebooten – viel Spass beim Testen …

Feb 23 2016

Nagios – Prüfung Prozess auf Remote Linux System

Hallo,

ein Nagios mit Version 4 läuft bei mir schon lange (derzeitig auf einem Ubuntu 14.04 LTS).

Die meisten Serversysteme prüfe ich auf Erreichbarkeit (PING) – bei einigen Windowssystemen habe ich jedoch auch zwischenzeitlich Prozessprüfungen oder Kapazitätsprüfungen hinzugefügt.

Da ich nun auch auf einem Raspberry PI (v1) ein paar Dinge laufen lasse, möchte ich nun eine Prozessprüfung darauf machen mittels NRPE (Nagios Remote Plugin Executor).

Auf dem Raspberry läuft für eine TK-Anlage Musik in der Dauerschleife – dieses Prozess (mpd) will ich prüfen.

Nachfolgend mein kleiner Aufschrieb meiner Config.

Starten wir mit der CONFIG auf dem Raspberry (remote host):

Zunächst muss auf dem Raspberry den NRPE Server installieren werden mittels

Ist dies geschehen, muss in der NRPE Config den Nagios Server als Host hinterlegen, damit sich dieser verbinden darf.

Hierzu muss die Datei

in der Zeile

erweitert bzw. ergänzt werden.

Die Konfigurationsdatei /etc/nagios/nrpe.cfg enthält bereits vordefinierte Kommando Definitione, welche genutzt werden können.

Für meinen Fall füge ich ein zusätzliches Kommando hinzu (hervorgehoben).

Hierbei prüfe ich den Prozess mpd (-C mpd), ob dieser ausgeführt wird oder nicht.

Mit dem Parameter „-c 1:1“ wird angegeben, das wenn 1 Prozess läuft, die Abfrage OK ist – läuft er nicht, ist er „kritisch“

In der Config können noch weitere Änderungen gemacht werden – je nach Anforderung.

Damit es später auch keine Rechte-Probleme mit der (remote-)Ausführung gibt,

sollte für den User „nagios“ eine Ausnahme in der Datei

gemacht werden.

In meinem Beispiel habe ich die Ausführung aller PlugIn Scripte erlaubt

Aber zum Schluss nicht vergessen, den Daemon neu zu laden.

 

Weitere gehts mit der CONFIG auf dem NAGIOS Server…

Hier muss sichergestellt werden, das die NRPE Plugins installiert sind.

Falls nicht, können diese (und nur diese) wie folgt nachinstalliert werden.

Mit der Option „–no-install-recommends“ wird verhindert, dass Nagios mit installiert wird.

Nun muss ein neuer Prüfprozess im Nagios erfasst werden

Fix noch eine Hostzuweisung des Checks machen und Nagios reloaden.

Dann sollte es hoffentlich wie folgt aussehen.

blog-raspi-nrpe

Viel Spass nun beim testen …

Jan 15 2016

Upgrade Kodi auf Version 15.2

Hallo zusammen,

nachdem auf meinem Raspberry seit längerem Kodi (früher auch unter XBMC bekannt) mit Version 14.2 lief, war es mal wieder an der Zeit zum upgraden – aber wie?

Bei „Prof. Google“ fand ich verschiedene Wege. Viele sagten, mache ein Backup, exportiere die Einstellungen, ziehe eine Neuinstallation über die SD-Karte drüber und spiel die Config zurück – ein möglicher Weg, für mich aber der unbequemste 😉

Es gibt einen viel einfacheren Weg (zumindest aus meiner Sicht).

Lade zunächst das Update von der OpenELEC Seite herunter – zum Zeitpunkt dieses Artikel’s war es Version 15.2 (stabile).

Achte darauf, das du die richtige Datei herunterlädst – in meinem Fall für den Raspberry B+ war es diese Datei.

Standardmäßig ist im Kodi das SMB Zugriff aktiv und die kannst mit dem Windows Explorer bequem darauf zugreifen.

Öffne einfach im Windows Explorer die IP Adresse deines Raspberry’s – in meinem Falle ist es

Das ganze sollte dann wie folgt aussehen:

Kodi_Update_01

Nun siehst du viele freigegebene Ordner. Wichtig ist dabei der Ordner „Update“ – dieser sollte eigentlich leer sein.

Kopiere in diesen Ordner nun die zuvor heruntergeladene Updatedatei hinein.

Kodi_Update_03

Nun ist ein Reboot des Raspberry’s nötig – wie du das machst, ist dir überlassen.

Um den Versionssprung etwas deutlicher zu machen, mache ich das ganze über einen SSH Zugriff.

Vor dem Update lief noch die Version 14.2 von Kodi bzw. die Version 5.0.8 von OpenELEC.

Blog_Kodi_Update_02

Den Reboot nun einfach mit dem Befehl „reboot“ starten.

Blog_Kodi_Update_04

Nun braucht der Raspberry einen Moment. Beim Neustart wird der Updatevorgang ausgeführt.

Zeit sich eine Tasse Kaffee zu holen, dann sollte das Update durch sein.

Auf der SSH Konsole findet man nun zumindest die aktualisierte Version 6.0.0 von OpenELEC.

Blog_Kodi_Update_05

Von nun an läuft auf dem Raspberry die Version 15.2 von Kodi.

Viel Spass nun beim testen …

Dez 18 2015

Installation Nagios 4.1 auf einem Ubuntu 14.04 LTS

Hallo zusammen,

anbei mein Aufschrieb zur (frischen) Installation eines Nagios 4.1 auf einem Ubuntu 14.04 LTS.

Gegeben ist ein Ubuntu 14.04 LTS voll gepatched.

1.) Installation des LAMP Paketes

2.) Starten des Apache Dienstes

3.) User und Gruppe für Nagios erstellen

4.) Zuordnung zum Web

5.) Installation von Nagios Core

Nun noch eine Config für den Apache erzeugt …

Öffne diese .conf und füge folgendes ein:

6.) Konfiguration des Apache Users:

Bei Aufruf der Webadresse wird diese durch einen User gesichert. In diesem Falle der User „nagiosadmin“.

Diese kann natürlich auch geändert werden.

7.) Aktivieren der nagios Apache Konfig

Aktiviere nun die nagios Apache Config. Zusätzlich muss noch das cgi Modul aktiviert werden und ein Neustart des Apache ausführen.

8.) Download und Installation der Nagios Plugins

9.) Nun noch die Sourcen kompilieren und installieren

10.) Nagios Config prüfen und Nagios Deamon und starten:

11.) Aufruf Nagios Webfrontend

12.) Viel Spass beim konfigurieren … 😉

Dez 12 2015

Exchange 2013 SP1 – Upgrade auf CU10

Hallo zusammen,

 

gegeben ist ein Exchange 2013 mit Stand SP1 (=CU4).

Da die CU’s nicht automatisch installiert werden können, müssen diese von Hand installiert werden.

Anbei eine (meine!) Beschreibung, wie ich eine Installation aktualisiert habe.

  1. Download Exchange 2013 CU10 (ca. 1,6 GB!)
  2. Download Exchange 2013 CU10 LanguagePacks

Hinweis!

Die Exchange CU(s) sind nicht nur reine Upgrades. Diese werden auch bei Neuinstallation verwendet.

Achtet daher auf die korrekte Handhabung, nicht das eine vorh. Exchangeinstallation „platt“ gemacht wird.

 

Zunächst entpacke als ersten Schritt das CU10. Einfach einen Doppelklick auf die .EXE und ein Verzeichnis angeben.

Ex2013-CU10-01

Als nächstes sollte das AD-Schema erweitert werden.

Hierzu eine administrative CMD öffnen und folgendes ausführen:

Ex2013-CU10-02

Nun kann das eigentliche Upgrade starten – ich habe mich für die grafische Installation entschieden.

Mache dazu einen Rechtsklick auf die „setup.exe“ und wähle „Als Administrator ausführen“ aus.

Nach dem Start des Setups möchte das Setup selbst nach Updates suchen, was ich erlaube (und empfehlen würde)

Ex2013-CU10-03

Es wird nach Updates gesucht. Werden welche gefunden, werden diese mit berücksichtigt – in meinem Falle gab es keine …

Ex2013-CU10-04

Nach einen Klick auf „weiter“ werden zunächst ein paar Daten kopiert.

Ex2013-CU10-05

Das Setup erkennt die installierte Exchangeinstallation und bietet (logischerweise) das Upgrade an (sonst würde was schief laufen …).

Siehe auch Hinweis am Anfang bzgl. Neuinstallation / Upgrade durch ein CU.

Ex2013-CU10-06

Nun müssen die Lizenzbedingungen bestätigt werden.

Ex2013-CU10-07

Es werden nun ein Prüfungen vorgenommen.

Sind Vorraussetzungen nicht erfüllt, erscheinen Warnungen oder Fehler.

Läuft alles gut (wie in meinem Falle), bietet das Setup die Installation an.

Ex2013-CU10-08

Die Installation läuft nun. Dieser Vorgang dauert nun eine Weile (je nach Umgebung auch mal 30min oder mehr …)

Ex2013-CU10-09

Warten ist nun angesagt

Ist das Setup fertig, erscheint eine abschließende Meldung.

Ex2013-CU10-10

Starte nun den Exchange Server neu und melde dich anschließend im ECP an.

Prüfe nun dort die Version unter SERVER -> rechte Seite

Ex2013-CU10-11

Perfekt, die Version 15.0.1130.7 ist das CU10 (siehe auch MSXFAQ – Exchange Build Nummern).

Viel Spass nun beim testen…

Dez 01 2015

pfSense 2.2.x – IPSec Site-to-Site VPN

Hallo,

ich möchte hierbei mehr eine Doku erstellen, wie ich ein Site-to-Site VPN zwischen 2 Standorten realisiert habe mit 2 pfSense (www.pfsense.org) Appliances.

Als Basis habe ich folgende Konfiguration

  • 2x APU1D4 Appliances.
  • In der Zentrale läuft das Release 2.1.5, in der Zweigstelle läuft bereits das Release 2.2.5.
  • IP Netz Zentrale: 192.168.100.0 / 24
  • IP Netz Zweigstelle: 192.168.110.0 / 24

 

Hinweis: die Konfigurationsparameter müssen, bis auf wenige Ausnahmen identisch sein, sonst klappt die Verbindung nicht.

Sollte es noch nicht geschehen sein, so muss IPSec aktiviert werden (VPN -> IPSec -> Enable IPsec).

Konfiguration IPSec in der Zentrale (lokales Netz 192.168.100.0/24)

vpn_01

vpn_02

vpn_03

Erstelle nun noch eine Phase2 Konfiguration:

vpn_04

vpn_05

Konfiguration IPSec in der Zweigstelle (lokales Netz 192.168.110.0/24):

vpn_06

vpn_07

vpn_08

Auch hier muss eine Phase 2 erstellt werden:

vpn_09

vpn_10

 

Wenn alle beiden Seiten korrekt konfiguriert wurden, sollte die Verbindung klappen.

Dies kann unter STATUS -> IPSec geprüft werden.

Zentrale:

vpn_11

Zweigstelle:

vpn_12

Ich weis nicht, ob alles „perfekt“ konfiguriert ist oder ob etwas optimiert werden könnte. Jedoch funktioniert es.

Viel Spass beim testen …

Nov 17 2015

Windows 10 – Edge Browser als Administrator nicht ausführbar

Hallo,

unter Windows 10 ist, aus Sicherheitsgründen, z.B. das Ausführen des Edge Browser’s (aber auch andere Programme) unter dem Administrator Account zunächst nicht ausführbar.

Wer es dennoch versucht, bekommt folgende Meldung zu Gesicht:

Win10-Edge-01

Wer es dennoch nutzen möchte, muss nur eine Kleinigkeit ändern.

Öffne dazu die lokalen Sicherheitsrichtlinien durch (Rechtsklick auf Startsymbol) ->  „Ausführen“ -> „secpol.msc“ eintippen -> Rechtsklick und „Als Administrator ausführen“.

Win10-Edge-02

Gehe anschließend unter „Sicherheitseinstellungen“ -> „Lokale Richtlinien“ -> „Sicherheitsoptionen“ und aktiviere die Option

„Benutzerkontensteuerung: Administratorgenehmigungsm.“

Win10-Edge-03

Nach einem Neustart des Systems ist die Nutzung des Edge Browser unter dem Administrator auch möglich.

ABER – VORSICHT: Diese Option ist nicht um sonst standardmäßig deaktiviert!

Man sollte aus Sicherheitsgründen verzichten, mit administrativen Accounts sich im Internet zu bewegen (zwecks Viren etc.)

Daher erfolgt die Umstellung und die Nutzung auf eigene Gefahr!

Dennoch viel Spass beim Testen…

Ältere Beiträge «